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Getting Started with MARPLOT

This section provides a hands-on guide to the most common MARPLOT
functions. It uses the sample Prince William County, VA map that was
distributed with your MARPLOT system. This guide is meant to be used
interactively while you work at the computer with MARPLOT. You will get the
most out of it if you perform each step on your MARPLOT system, and try all of
the suggested tasks.

Further examples of various MARPLOT functions are given in Chapter 5.

3.1  Starting and exiting MARPLOT

On Windows...

To start MARPLOT, double-click its icon in the Program Manager or select
MARPLOT from the taskbar Start menu. Click OK on the greeting screen.
To exit MARPLOT, choose Exit from the File menu in the upper-left
corner of the MARPLOT map window.

On Macintosh...

To start MARPLOT, double-click its icon in the Finder. Click on the
greeting screen. To exit MARPLOT, choose Quit from the File menu.

3.2  Guided tour of basic MARPLOT functions

IMPORTANT NOTE:

For CAMEO users...

This guided tour makes use of objects on the CAMEO Map. The CAMEO
Map is a folder (directory) stored in the same place as your CAMEO
database or stack files. You must run MARPLOT and CAMEO
simultaneously on your computer at least one time before going through
this tour. To do this, start both programs and enter any necessary
passwords. Make sure you see the CAMEO Map objects in MARPLOT.
Then quit both programs. After having done this, the CAMEO Map
objects will continue to appear in MARPLOT, even when CAMEO is not
running.

For non-CAMEO users...

This guided tour makes use of objects on a map called CAMEO Map. Even
if you do not have this map, you should be able to follow along with most
steps of the tour. If you do have it, but you are not a CAMEO user, you
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should put it into your MARPLOT folder (directory) before going through
the tour.

Showing Different Layers

1. Start MARPLOT.

2. After you click on the title screen, MARPLOT opens the map window. The
sample map, Prince William County, is shown. (If, for some reason, your
MARPLOT does not open to this view, use the Go to View item in the View
menu, highlight the <entire map> view for Prince William County, and click Go
to View.)

Note: Your map window may not look exactly the same as the one shown in the
picture above. The scale value shown at the top of the window will probably be
different.

3. A number of different layers are shown, including the Places layer showing
the various towns in Prince William County, the water layer, and several
CAMEO objects, which are all clustered in the northern part of the county. With
the arrow tool, click several times on the map. As you select objects, they become
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highlighted with red dots, and MARPLOT displays their name at the bottom of
the map window. Also, the location of your click is marked with a flashing icon
called the Focus Point. The latitude/longitude coordinates of the Focus Point are
shown in the upper-left corner of the map window.

          

4. From the View menu, select the Redraw item. Watch the bottom of the map
window as MARPLOT draws. It shows which layer is being drawn. Use the
Redraw item a couple more times to get a feel for how long it takes MARPLOT to
draw the different layers on your computer.

5. Use Redraw one more time, but this time, try to press the ESC (escape) key as
soon as MARPLOT starts drawing the Water layer. Pressing the ESC key causes
MARPLOT to stop drawing. It displays the message [DRAW INCOMPLETE] at
the bottom of the map window to remind you that all of the layers to be drawn
were not drawn. Even when the drawing is incomplete, however, you can still
click on the map with the arrow tool to select any object that would have been
drawn. With the map partially drawn, try clicking on some of the CAMEO
objects in the northern area of the county.

          

6. Use Redraw one more time to display all of the shown layers.

7. From the list menu, select the Layer List item. This brings up MARPLOT’s list
of layers. The layers can be sorted alphabetically or from top to bottom according
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to the order in which they are drawn. Currently the layers are sorted in draw
order. Scroll up and down in the list of layers. Notice that the TIGER-derived
layers such as Places and Roads are lower in the list than the CAMEO layers such
as Facilities and Hospitals. Since the layers are shown according to the draw
order, this means that the TIGER-derived objects will draw first, on the
“bottom,” and then the CAMEO objects draw after, on the “top.”  That’s why,
when we stopped the drawing, we saw some of the TIGER layers (the shoreline,
the places, and some of the water) but the CAMEO objects still hadn’t been
drawn.

8. In the Layer List, click on the names of different layers. Notice that, in the
bottom part of the window, MARPLOT displays the number of objects on that
layer, and also some graphical information about the layer.
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9. As can been seen in the columns in the center of the Layer List, all of the
CAMEO layers are currently in “Show” mode, and most of the TIGER-derived
layers (roads, railroads, etc.) are currently in “Range” mode. When a layer is in
Show mode, it displays no matter what the map scale. When a layer is in Hide
mode, it does not display. When a layer is in Range mode, it displays only within
a certain range of map scales. For now, let’s put all of the non-CAMEO layers
except for the Places layer into Hide mode. To do this, click on each layer’s line in
the Hide column.

10. Click OK. The map is redrawn with just the Places and CAMEO layers
shown.
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11. Return to the Layer List dialog box using the Layer List menu item again.
This time, set the Roads layer to Show mode by clicking in the Show column of
the Roads layer’s line.

12. Click OK. The map is redrawn with the Roads layer shown.

13. It takes a significant amount of time to draw all of the roads at this zoomed-
out view of the entire county. It would be better to draw the roads only when we
are zoomed in closer. That way, we wouldn’t have so much to draw at one time.
This is just what the Range setting in the Layer List dialog box is for. Return to
the Layer List and set the Roads layer to Range mode. In order to see what range
of scales the roads will show in, make sure the Roads layer is highlighted in the
list and then click on the Scale Ranges button.
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14. The Layer Scale Ranges dialog box displays and lets you modify four scale
values: the most zoomed-out scale the layer will display at, the most zoomed in
scale the layer will display at, the scale you have to zoom in to before objects on
the layer are labeled with their names on the map, and the scale you have to
zoom out to before symbol objects on the layer are displayed as dots instead of as
their usual icons.

15. Note that, in the case of the Roads, the layer is set to show when the scale is
about 1 inch = 2 miles. Note that our current scale is more zoomed out than that.
Thus, if we leave these scale values, and leave the Roads layer in Range mode,
we’ll have to zoom in a bit close for the roads to appear.

16. Click OK to exit the Layer Scale Ranges dialog box, and then click OK to exit
the Layer List dialog box. Notice that the roads are no longer displayed. Let’s
zoom in closer using the magnifying glass tool, . Click on this tool and then,
with the magnifying glass, click about in the center of the county. This causes the
view to zoom in by a factor of 2, centered on the point of your click. Note that the
number of miles per inch has been cut in half. (Note: You may find that after
zooming the Places layer containing the county and cities is hidden.)

          

17. The roads still do not display because, as we saw in the Layer Scale Ranges
dialog box, they are set to show only when we are zoomed in to at least 1 inch =
2 miles. Click one more time with the magnifying glass, again around the center
of the map window. Now the roads appear because we have zoomed in past the
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threshold scale. If we continue to zoom in with the magnifying glass tool, we can
reach the scale at which the names of the roads appear. (Note: Depending on the
settings in your copy of MARPLOT, you may have to zoom in a bit father to see
the road names.)
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18. You may also have noticed that, as we were zooming in, the cities and towns
disappeared. That is because the Places layer, like the Roads layer, is currently in
Range mode, and the Places are set to turn off when we zoom in past a certain
scale. To see this, return to the Layer List dialog box, highlight the Places layer
and click on the Scale Ranges button.

19. Since it’s true for most layers that you’ll only want to see them within a
certain range of scales, it is common for most of the layers to be set to Range
mode. There are some exceptions. For instance, there may be relatively few
objects on certain layers, such as the CAMEO layers. Since these layers draw very
quickly, you might want to leave them always in Show mode. On the other hand,
consider the Census Block Groups layer. This layer contains a large number of
polygons that take a while to draw. It’s not that you want them to show only
when you are zoomed in close. Rather, you will probably want to keep them in
Hide mode until you need them, set them to Show mode while you work with
them, and then set them back to Hide mode.

20. For now, let’s set all of the TIGER-derived layers except for the Census Block
Groups layer back to Range mode. As you do so, you may want to click on the
Scale Ranges button to see the range setting for some of the other layers. Then
use the Go to View dialog box to return to the <entire map> view for Prince
William County.
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Navigation and Views

21. In the preceding steps, we’ve already seen two ways to navigate around the
map: the Go to View dialog box, and the plus magnifying glass tool. You may
have guessed that the minus magnifying glass tool  is used to zoom out, also
by a factor of 2. Two other tools along the left edge of the map window are also
used for changing the view. The hand tool  is used to shift the map view
without changing the scale. The plus magnifying glass tool  can also be used to
zoom into a particular rectangular area. Select the plus magnifying glass tool
now by clicking on it. With the entire Prince William County map in view, notice
the two hospitals objects (red crosses) among the CAMEO objects. Let’s zoom
into an area just big enough to show both hospitals. Click with the magnifying
glass above and to the left of the top hospital. With the mouse button still down,
drag below and to the right of the bottom hospital. A gray box defines the region
as you drag. When you have just surrounded both hospitals, release the mouse
button. MARPLOT changes the view to show the area defined by the rectangle.

Note: If you make a mistake using the magnifying tool, you can always return to
the last view using the Go to Previous View item in the View menu. Also, if you
start defining the rectangle and then decide you don’t want to zoom after all, you
can press the ESC key while the mouse is still down to abort the zoom.
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22. The new map window now displays the selected area. We can save this view
for future reference. Select the Save Current View item from the View menu.
Name the view “Two Hospitals” and click OK.

  

23. To show how the view is used, use the hand tool to shift the map view. To do
this, click with the hand tool near the top of the view, drag down to the bottom of
the window and then release the mouse button. This shifts the view to the north.
Now select the Go to View item in the View menu, highlight the Two Hospitals
view, and click Go to View. You are returned to the saved view.
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24. Use the Go to View dialog box again to return to the <entire map> view of
Prince William County. Let’s save this view also, using Save Current View. Let’s
name it PWC Image.

  

25. Another use for saved views is as a reference view. To see how reference
views work, return to the Two Hospitals view again using Go to View. Then
click on the triangle in the upper-right corner of the map window, go to the
Reference View submenu, and choose Set. Select the PWC Image view, leave the
“allow any view in reference” box unchecked, and click Set Reference View.
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26. The reference view, showing the PWC Image, appears in the upper-right
corner of the map window. The reference view shows the location of the current
view in the map window relative to some other view. In this case, we see the area
of the Two Hospitals view relative to the entire area of Prince William County.
The flashing red box indicates the shown area.

          

27. Use hand and magnifying glass tools to move all around the map. Notice
how the flashing rectangle in the reference view follows you. Zoom in as far as
you can go. Notice that, when the flashing rectangle gets too small, it is replaced
by a cross-hairs, pinpointing your location. You can double-click at a point on the
reference view to view that area. Try double-clicking a few times on the reference
view. Also, by clicking once and dragging on the reference view rectangle, you
can reposition it in the map window.

28. Let’s try one more experiment with the reference view. Return to the Two
Hospitals view using Go to View. Click once with the plus magnifying glass in
the center of the map window. Now set the reference view again, this time
choose the Two Hospitals view as the reference view (again, leave the “allow any
view in reference” box unchecked). As we saw before when using PWC Image as
the reference view, here the Two Hospitals is serving as a reference view and the
flashing rectangle shows the area of the current map window relative to it.

          

29. This time, however, notice what happens when you use the minus
magnifying glass to zoom out two times. As soon as the view in the map window
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no longer fits within the Two Hospitals reference, MARPLOT automatically
changes the reference view to the PWC Image. If you then zoom back into an
area within the Two Hospitals view, MARPLOT automatically changes the
reference view back to the Two Hospitals view. These automatic changes happen
because we had the “allow any view in reference” box unchecked when we set
the reference view. When this box is checked, MARPLOT allows a view to stay in
the reference view, even when the current map view does not fall completely
inside of it.

          

30. When you have saved a view and are sure you no longer want to work with
it, you can delete it using the Edit Views item in the View menu. Select Edit
Views now and delete both the Two Hospitals view and the PWC Image view.
Click OK. Notice that the reference view is closed automatically because we
deleted the view it was using.
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Searching for Cities and Roads

31. One of the most common operations you will perform in MARPLOT is
searching for an object, often for an address range or intersection of a certain
road. Another common search, if you are working in a large county, is to find a
certain city or town within the county. Let’s search for a town within Prince
William County. Bring up the Search Criteria dialog box by selecting Search from
the List menu.

32. Click on the pop-up box after the label “Search for objects that:” and select
“have any name.”  After “Layer(s) to search:” choose “Individual Layer...” in the
first pop-up box and “Places” in the second pop-up box. After “Map(s) to
search:” choose “Maps in View” and leave the final pop-up box set to “replace
previous collection.”  Then click the Search button.

33. MARPLOT performs the search, and puts all of the objects that match the
specified criteria into the Search Collection. In this case, we found all of the
objects on the Places layer of the Prince William County map. The Places layer
contains one polygon object representing each city or town in the county, plus a
single polygon object representing the boundary of the entire county.
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34. Find “Dumfries town” in the list and click on its name to highlight it. Click
the Show on Map & Zoom button. This causes MARPLOT to change the view so
that Dumfries town just fits into the map window.

35. You may recall from earlier in this guided tour that the Places layer was set to
Range mode, and normally the Places would not be visible at this new scale
where Dumfries town fills the map window. However, since we asked
MARPLOT to show Dumfries town on the map, it automatically changed the
Places layer to Show mode. Let’s go back to the Layer List and set the Places
layer back to Range mode.
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36. Now we see the same area without the Places polygons cluttering the view.
There is a street in Dumfries town named “Fairfax St.”  Let’s use the Search
function to find this street. In the Search Criteria dialog box, search for objects
that “have names that start with.”  Type the letters “fair” in the box that appears
in the upper-right. Search on the “Individual Layer” named “Roads.”  Again,
search on “Maps in View” and choose “replace previous collection.”  Click
Search.

37. Again, the Search Collection dialog box comes up with the results of the
search. Highlight “Fairfax St” and click Show on Map (we do not use Show on
Map & Zoom this time because we don’t want to change the viewing scale; if we
had used Show on Map & Zoom, MARPLOT would have changed the view to
show just the area covered by Fairfax St in the map window).
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38. MARPLOT highlights Fairfax St on the map with red dots and shows its
name at the bottom of the map window. It also puts the Focus Point at the center
of the street.

39. Use the plus magnifying glass tool to zoom into an area that shows just
Fairfax St, plus a little extra space for borders.

          

40. Suppose we want to know where the address 250 Fairfax can be found. Go
back to the Search Collection using the Show Search Collection item in the List
menu. With “Fairfax St” highlighted, click on the Addresses button.

41. MARPLOT displays the list of address ranges for Fairfax St. In this case, we
see that there is an error in the TIGER data: the bogus address range 0-109. The
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example in section 5.1 shows how you can correct this type of data error. For
now, we are looking for address 250, which falls within the range 210-299.
Highlight this range in the list and click Show on Map.

42. MARPLOT shows the location of the address range by positioning the Focus
Point at the center of the segment that corresponds to the selected range.

43. Now suppose we want to find the intersection of Fairfax St and Duke St.
Again, bring up the Search Collection using the Show Search Collection item in
the List menu. With Fairfax St highlighted, click on the Intersections button.
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44. MARPLOT lists all of the streets with which Fairfax St intersects. Highlight
Duke St in the list and click Show on Map (Show on Map & Zoom would change
the scale to an appropriate scale for viewing the intersection, but in this case we
are already at such a scale).

45. MARPLOT selects both Fairfax St and Duke St, and puts the Focus Point at
their intersection.

46. This concludes the MARPLOT guided tour. If other people will be taking this
tour using this MARPLOT system, please use the Go to View dialog box now to
return to the <entire map> view for Prince William County. Then exit from
MARPLOT. You can find more step-by-step examples of using MARPLOT in
Chapter 5.




